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ABSTRACT 

As more and more organizations adapt to the SAS Enterprise Guide, switching smoothly from PC SAS to SAS 
Enterprise Guide and reducing the learning curve becomes remarkably important. The tips from work experiences 
can help maintaining productivity efficiency and revealing the powerful capabilities of SAS Enterprise Guide during 
this transition. 

This paper presents tips from firsthand experiences of using SAS Enterprise Guide. Setting up a working environment 
by choosing preferred options in the tool manual is a great start for programming.  Using work space layout, the ‘send 
to’ option and other devices to utilize MS applications as additional tools can improve work efficiency.  Grouping 
programs as projects will facilitate to work with multiple programs and even multiple projects at the same time. 

These applicable ways of using SAS Enterprise Guide will ensure a fast adaptation to SAS Enterprise Guide for both 
new and experienced SAS programmers, particularly the programmers working in Pharmaceutical industry. 

INTRODUCTION 

SAS Enterprise Guide working environment is different from PC SAS.  While some features in SAS Enterprise Guide 
are improved from PC SAS, others are totally new.   This paper will provide step by step instructions for mastering the 
basic features of the SAS Enterprise Guide and address feature availabilities for the best use of SAS Enterprise 
Guide. 

WORKING ENVIRONMENT: SAS ENTERPRISE GUIDE vs. PC SAS 

Unlike PC SAS which only has two major windows, SAS Enterprise Guide has 3 major windows (Display 1).  The 
Work Area window is where you write, edit and run the program, as well as review the log and outputs. It also 
presents the process flow and links in the SAS Grid.  Project window is a “Project Tree” panel where it lists all 
programs saved in a project and data sets opened or generated by running of the programs.  The Server and Library 
windows are in the “Server List panel” where user defined and work libraries are displayed.  Task Window displays 
message about the status of running program. 

 
Display 1. SAS Enterprise Guide Interface 



2 
 

During the time of transferring from PC SAS to SAS Enterprise Guide, knowing the difference between PC SAS and 
SAS Enterprise Guide (Table 1) will guarantee the PC SAS user a fast transition.  It will reduce the learning curve by 
focusing on the new features and functions.   

Traditional PC SAS SAS Enterprise Guide New in SAS Enterprise Guide 

Program Window Code Edit Window  Code assistant  

SAS Explorer Server List Window  Tree structure 

None SAS Grid Display Window 

Process flow - Display program flows 
and links with data and log and list 
files 

None Project Window 
Project Trees, objects and 
components 

Results Window SAS Grid Window  More display options 

None Task Status Window 
 Table 1. Comparison between traditional PC SAS and SAS Enterprise Guide 

PROGRAMING IN SAS ENTERPRISE GUIDE 

SAS Enterprise Guide is famous for its point and click method to generate a quick report and graph.  In the 
Pharmaceutical industry, statistical programmers prefer to save their programs for future rerun and editing.  This 
section will focus on the practical ways of coding and editing program to produce the desired result using SAS 
Enterprise Guide.   

OPTIONS USAGE 

Once you start to use SAS Enterprise Guide as a primary application, making yourself familiar with its options is one 
way to increase your productivity. You can choose Tools -> Option to see the list of available selections.  Go 
through each option category and place the cursor on the selection and the box underneath will show the text which 
specifies the option you selected.  (Display 2)  

 

Display 2. SAS Enterprise Guide Option Menu 



3 
 

SAS Enterprise Guide provides a lot more customizations than PC SAS through options setting.  Some options are 
expedient for users who want to do a quick data analysis.  Other options are great for code writing.  The following 
sections will discuss the most valuable options for users who prefer code writing. 

 Editor Options is the first option you need to configure by clicking Options -> SAS Programs -> Editor Options.  
There is the General option, Appearance option, Autocomplete option and Indenter option.  These selections 
allow you to customize the code edit environment based on user’s preference. Commonly used routes are Show line 
number which can help debugging, Insert space for tabs where the tab size can be customized and Automatic 
Indentation option.  The Appearance options allow users to pick the character font, style, size, color and much 
more, while the Review pane at the bottom shows users the appearance of characters after configured (Display 3). 

 
Display 3.  Enhanced Editor Options and Sub Menu for Appearance option  

Result Option is one of the most useful assortments.  SAS Enterprise Guide offers more output formats than PC 
SAS.  The output formats can be SAS report, text output, RTF, HTML or PDF formats.  HTML output is easy and 
clearer than text output for results review.   Users can also select display option to display log, automatically show 
data or results after program run.  However, if generated data or results are very large, it can affect performance in 
SAS Enterprise Guide.  In a similar situation, automatically add output data to the project tree option can affect 
performance with large data input or generated.  These two options can be turned off (Display 4) when large data 
sets are involved.  This way the user can view input and output data at libraries in the Server List window when 
needed without sacrificing performance.  

 

Display 4.  Result Display Option Window 

Another option you want to choose is Replace results option.  It is better to select Replace without prompting 
option (Display 5).  Otherwise, you will be prompted to select ‘Yes’ or ‘No’ to replace the results from the previous 
run.  In a normal situation, you don’t want to save changes to a new task which will create a new program with a new 
name.  
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Display 5.  Pick ‘Replace without prompting’ Option 

ORGANIZE PROGRAMS AS A PROJECT  

SAS Enterprise Guide provides Project Tree Window which PC SAS does not have.  This new feature offers most 
useful capabilities of grouping all the relevant objects such as data, code, log and results contained within a project 
(Display 6).   Clinical SAS programmers have experience of writing multiple programs for one project or working on 
multiple projects.  Grouping programs under the same project allows users to switch and work around on different 
programs or multiple projects efficiently and effectively.    

As example below shows, programs ddemo, ldemo and tdemo have been saved under “Project_1”.  In reality, it is 
better to give a meaningful project name related to the project.  In the SAS Grid Display Window, the process flow 
provides the links of the programs with data and results generated.  When you click the program name in the Project 
Tree window, the program will open and is ready for viewing or editing.  The user can switch and work on different 
programs easily and avoid any possible mess up. Most important is that the project has been saved and will be 
available any time the users open the saved project.  

 

Display 6.  Sample of multiple programs under a project 

The project can be created by clicking New Project and select File -> Save Project or “Ctrl + S”.  You will be 
prompted to give the path and project file name.  The project file with extension “.egp” can be saved on a server or 
locally and does not have to be saved in the same directory as the programs.  The programs can come from different 
paths as well.  Next time the project is opened, all programs under this project can be opened and available to edit or 
run.  Please remember to save the project again after adding new programs under the project. 

 EDIT AND RUN PROGRAMS IN SAS ENTERPRISE GUIDE 

Run the program function in SAS Enterprise Guide is very similar to traditional PC SAS.  SAS Enterprise Guide has 
two selections for running – Run and Run Selection.  F8 and F3 are the short cut for “Run” and “Run Selection”, 
respectively.  After submitting the program, both data and results in your selected format (See Result Option section) 
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will show at the top bar.  There are two key parts that need to be paid attention to by the user:  1) Run Selection is 
only available when the codes are selected.  Otherwise, the whole program will be submitted.  2) Remember to click 
F3 or F8 in the program edit work space for the current program run.  If you click F3 or F8 in log or project flow work 
space, all programs in a project will be submitted.   

In additional, SAS Enterprise Guide provides a visual sign for each performance of the program.  An asterisk * means 
that the program has been edited but not saved.  A red ‘X’ means that there is an Error in the log.  A yellow triangle 
with “!” means there is a Warning in the program log.  Just by looking at the signs, the users will know immediately 
whether the program ran successfully or not (Display 7). 

 

Display 7.  Warning or Error Signs for the log 

Another interesting feature in SAS Enterprise Guide is that a user can schedule time to run programs in a project.  
This new feature saves user time to click open and run individual program.  It achieves the same result as you batch 
submitting programs in PC SAS but it offers flexibility by predefined program run time (Display 8).   

 

Display 8.  Schedule project run 

SAS Enterprise Guide was designed to simplify the life of a SAS user.  It provides the code assistant to the user.  It is 
a big benefit for new SAS programmers as well as experienced SAS programmers as they may occasionally forget 
some syntax of a procedure or a function.  The complete documentation of the procedure or function will show when 
the cursor hovers over the procedure or function name.  In the middle of entering the code, code assistance will pop 
up to provide code help for the procedure or function (Display 9). 
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Display 9.  SAS Enterprise Guide code assistant system 

SAS Enterprise Guide not only provides code assistant but also has parentheses reminder.  It highlights parentheses 
so unclosed parentheses can be easily detected.  In the below example, the “(“ before “put” which does not pair up 
can be easily detected (Display 10).   

.   

Display 10.  SAS Enterprise Guide parentheses highlighting 

ANALYZE DATA IN SAS ENTERPRISE GUIDE 

Viewing data in SAS Enterprise Guide is convenient but inflexible when it comes to sort or filter.  The new feature of 
Query Builder in SAS Enterprise is a powerful tool to join tables. 

VIEW DATA IN SAS ENTERPRISE GUIDE 

SAS data sets can be viewed in different places. 

• Data sets generated by running a SAS program will be immediately available under the Output Data tab.  The 
user can view the data set by selecting the name of the data set (A) (Display 11). 

• Click the data set name in the Project Flow Window or libraries in Server List Window.  To view the most current 
data in the Server List, Refresh the library or data set in the library is necessary.  This can be done by selecting 
the library or data set name and right click the mouse and pick Refresh, or by clicking the Refresh button in the 
upper corner of the Server List (B) (Display 11). 
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Display 11.  View and refresh data set 

SORT AND FILTER DATA IN SAS ENTERPRISE GUIDE 

There is no quick sorting ability in SAS Enterprise Guide as PC SAS.  In SAS Enterprise Guide, the user needs to 
filter the data similar to the PC SAS Data -> Where feature but a little more complicated.  The good news is that SAS 
Enterprise Guide has a new feature which allows a user to save sorting or filtering task in the Project Tree window for 
later use. 

There are two ways to sort data.  1) Data -> Sort Data in the Output Data Menu.  Then select the variable / variables 
as primary or secondary sort key.  The primary sort key is always the first variable that is listed within the Sort by role.  
Next, select Ascending or Descending from the drop-down list.  Columns to be dropped means that the specified 
variables will not occur in the generated output data set (Display 12).  2) Similar to the traditional way resembling PC 
SAS, click Filter and Sort and select variables to be grouped in the output data set.  Next, assign the primary sort 
key variable in Sort by and the rest of the sort variables in Then by.  Finally, select Ascending or Descending Task 
(Display 13).  The new feature in SAS Enterprise Guide is that the defined task will be saved under the project tree 
and it can be viewed as needed or modified later by selecting Modify Task.  

 

Display 12.  Sorting method 1 in SAS Enterprise Guide 
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Display 13.  Sorting method 2 in SAS Enterprise Guide 

The Filter will retrieve particular data based on the values of the variables in the data.  It is very useful for checking or 
validating data.  The Filter function in SAS Enterprise Guide is similar to PC SAS.  Instead of going through Data -> 
Where as in PC SAS, SAS Enterprise Guide uses Expression Builder by first selecting variables, and then the value 
to be filtered and filter indicator “AND” or “OR” (Display 14).  The filter criteria can also be saved in the project tree 
window for future use or editing. 

 
Display 14.  Filter feature in SAS Enterprise Guide 

QUERY BUILDER IN SAS ENTERPRISE GUIDE 

Query Builder in SAS Enterprise Guide is a very powerful tool that can create a complex query that joins multiple 
tables together and creates computed columns.  PC SAS does not supply this feature.  Query Builder can make 
complicated queries by point and click in SAS Enterprise Guide.  It enables inexperienced users to join up to 256 
different tables by different join type (right, left, inner or outer) and create query report. Although most clinical SAS 
programmers may prefer to edit query code in a program, it is still a very useful tool for a quick check or used to 
assist in coding. 

To create a query to join tables, first select Query Builder, then add tables to your query.  Next, provide the join key 
variables of the left table and right table and select the join type.  If there are similar variable names between tables, 
SAS Enterprise Guide will guess at the join keys.  The user can also manually specify the join keys.  After assigning 
the join keys, join criteria and join type, click Run to create joined table by the selected condition (Display 15).  At this 
point, the query code is generated.  The user can Preview the codes and copy to a program as a reference (Display 
16).  
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Display 15.  Join Properties of Query Builder 

 
 Display 16.  Code Review in Query Builder 

PRACTICAL FEATURES IN SAS ENTERPRISE GUIDE 

There are some very practical features in SAS Enterprise Guide.  The work place layout allows a user to view 
multiple windows.  Sent out and copy to clip board features can help to leverage power of the other popular 
applications.  Ctrl + M short cut can enlarge the main window.  These and other tips can make programming tasks 
easier. 

WORK PLACE LAYOUT 

The ability to open multiple windows is very useful to analyze a program and data.  SAS Enterprise Guide has two 
ways to view multiple tables in split windows.  Select View -> Workspace Layout, then select Stacked or Side By 
Side (A).  There is also an icon on the top bar of the window.  It is much easier to pick Stacked or Side By Side on 
the pull down menu from this icon (B) (Display 17).  The work space layout allows a user to split the workspace 
screen to view multiple windows horizontally or vertically.  Users can examine SAS code with the log, data set or 
results at the same time.  It is especially useful when it comes to validating data with two data window view (Display 
18).  

 

Display 17.  Workspace Layout option 
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Display 18.  View two data sets at the same time  

QUICK WAYS TO EXPORT DATA OR DATA CONTENTS 

Viewing and sorting data in SAS Enterprise Guide does not have advantages over PC SAS, especially for quick 
sorting.  As an alternative, SAS Enterprise Guide provides an easier way to convert SAS data set to another 
application such as Excel, so the user can take advantage of Microsoft application to make a task more efficient. The 
Export function allows the user to save data in different file type (Display 19). The Send to feature is a much quicker 
way for fast data checking or analysis.  Both Export and Send To are under the main menu File.  When selecting 
Send To -> Microsoft Excel (Display 20), an excel file will automatically open.  Quick sorting or filtering can be done 
in MS Excel.  Unlike Export option which can convert a data set to multiple file formats, the Sent To option can only 
convert a data set into Microsoft Excel file.   The new file can be saved locally or on a server. 

 

Display 19.  Export in SAS Enterprise Guide 

 

Display 20.  Sent To feature in SAS Enterprise Guide 
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ADD COMMONLY USED CUSTOM CODE IN PROGRAM OPTION 

Program Option is a useful feature in SAS Enterprise Guide.  A user can add custom SAS code before or after a 
submitted program.  It also gives flexibility to add, edit, remove or comment out the codes as needed.  The option 
display is very similar to regular code edit.  A user can put most commonly used codes in the option window to make 
programming more efficient.  To access the SAS program option, select Options -> SAS Programs in the selection 
pane.  Then click the option you would like to add a custom SAS code to.  Insert custom SAS code before 
Submitted Code and Insert custom SAS code after submitted code are favorable options.  The code edit window 
will open by clicking Edit.  The user can create and edit custom code in the edit window (Display 21). After the global 
custom code is saved, the custom code will be submitted when the task is run. 

 

Display 21.  Add commonly used custom code in SAS Program option 

VIEW DATA CONTENTS 

SAS programmers often use PROC CONTENTS procedure to obtain columns properties such as variable name, type, 
length and label.  There is a new way to view data properties in SAS Enterprise Guide.  To access column properties 
of a data, click the property icon on right top of the main window bar when data is open (Display 22). Then select 
Columns, and the column properties will appear.  Another good feature in SAS Enterprise Guide is the Copy to 
clipboard function.  If you click the Copy to clipboard function, the column properties (name, type, format, informat, 
length and label) can be copied over other applications such as MS Excess, MS Word, NotePad or WordPad.  Users 
can study the data contents without pausing a program from editing or running.  It also allows programmers to 
compare different data sets properties with ease (Display 23). 

 

Display 22.  View column property icon 

 

Display 23.  Copy to clipboard feature 
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SAS Enterprise Guide also has an enhanced feature to view the properties of a variable.  You can use traditional 
methods to find the variable properties by right clicking the mouse on the variable and selecting properties (A).  Or, 
you can point the mouse at the variable - the properties of the variable will show up automatically (B).  Please note 
the Red quadrilateral icon indicates that the variable is a character variable, likewise it will display a blue icon if the 
variable is numeric (Display 24). 

 

Display 24.  View the property of the variable 

AN EASY WAY TO ENLARGE THE WORK SPACE WINDOW 

This is one of the favorable features in SAS Enterprise Guide.  A user can enlarge the work area by selecting View -> 
Maximize Workspace or click Ctrl + M.  The Project Tree and Server List windows will disappear, which will enlarge 
the work space giving more space for programming and viewing data or results.  The normal window can be brought 
back easily by click Ctrl + M again.  This handy short cut makes programmer life much easier (Display 25).  

 

Display 25.  Maximize Workspace View choice 

CONCLUTION 

SAS Enterprise Guide is a very powerful application.  It carries many great features and gives SAS programmers the 
opportunity to set up their own customized options.  These features and options give SAS programmers flexibility so 
efficiency can be achieved.  This paper addresses the basic and most common features, functions and options step 
by step based on firsthand experience.   These instructions and tips will help SAS programmers, especially those 
who are working in Pharmaceutical industry, to switch to SAS Enterprise smoothly. 

RECOMMENDED READING 

To gain a more complete understanding of Enterprise Guide, the author recommends the following 
http://support.sas.com/documentation/onlinedoc/guide/ 

http://support.sas.com/documentation/onlinedoc/guide/�
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