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ABSTRACT
Statistical graphics play an important role across various stages in clinical research. They help investigators to
explore and understand raw data in the early stage of statistical analysis, as well as present final analysis result in the
formal publications. The graphs need to be specifically designed and carefully drawn to best represent data and
analysis. While this can be done by SAS® programming using traditional SAS DATA steps and SAS/GRAPH
procedures, the process is time consuming and time is spent to find the right options or annotation syntax.
With SAS 9.2M3, ODS Graphics Designer (Designer) becomes production software. This is an interactive “point and
click” application that can be used to design and create custom graphs. This new application greatly enhances the
ability to effectively generate statistical graphs for clinical research.
In this paper, I will show you the application interface and walk you through creating some commonly used statistical
graphs for clinical research. The intended audience doesn’t need to know SAS/GRAPH syntax, but wants to create
high-quality statistical graphs for clinical trials. Examples will use scrambled data from real world in CDISC format.

INTRODUCTION
ODS Statistical Graphics is a new data visualization functionality available in SAS 9 to assist clinical research. It
provides the ability to create statistical graphs from many analytical SAS procedures, SAS/GRAPH Statistical
Graphics (SG) procedures, and SAS/GRAPH Graph Template Language (GTL). They are all based on SAS
programming syntax; the program can be simple and straight-forward few-line of code, or can be hundreds-line of
code with a pretty complex SAS syntax. This prevents statistician, analysts, and managers, who usually are not
familiar with the SAS syntax, from graphically exploring data or presenting their analysis results easily.
The new ODS Graphics Designer application (or “the Designer” for short) provides an interactive manual process to
generate statistical graphs without much knowledge of SAS/GRAPH software or the GTL. It makes it much easier to
design and create simple or complicated statistical graphs from early phase of clinical trials to late stage of regulatory
submissions.

EXAMPLE 1: EXPLORING THE USER INTERFACE
Figure 1 shows the Designer application interface that is started after submitting the following macro call from the
program editor window: %sgdesign; <submit>
On the left side is “Elements” pane which is two stacked panels, “Plot Layers” and “Insets”. On the right side is the
workspace with the “Graph Gallery”. The main menus are shown at the top such as “File”, “Edit”, “View”, etc. A
toolbar is shown below the menus.

GRAPH GALLERY
This gallery provides some predefined, commonly used plots. There are six groups of graphs, represented as six tabs
in the gallery:
1.

Basic: Scatter plots, histograms, and other basic plots.

2.

Grouped: Plots that have been grouped by a variable.

3.

Analytical: Commonly used analytical graphs.

4.

Custom: Graphs that require unique custom data.

5.

Matrix: Various scatter plot matrices for visualizing variable associations.

6.

Panels: Various types of classification panel graphs for comparison.
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Figure 1 The Designer User Interface
ELEMENTS PANE
Elements pane is inactive initially. It will become active once the process of creating a graph is started. The
Elements pane contains plots and insets that you can insert into the graph.
1.

The Plot Layers panel contains plots that you can click and drag to a graph cell.

2.

The Insets panel contains graphics elements such as legend, headers that you can click and drag to a graph
cell.

EXAMPLE 2: CREATE A BAR CHART OF GENDER FREQUENCY
A new graph can be created from a blank graph, or from a graph in the Graph Gallery. In this exercise, we’ll create a
graph from the gallery. Let’s start from one of the Basic graphs. We want to create a graph to plot the frequency of
gender for a clinical trial study.
If the Graph Gallery is not visible, select View->Graph Gallery.
Select the Basic tab from the Graph Gallery. Click the Vertical Bar. Click OK. (Or just double click the Vertical Bar)
A graph will appear showing a vertical bar chart, as shown in Figure 2A.
The Assign Data dialog is displayed with the default data settings for the bar chart. (Figure 2B).
We need to provide the LIBRARY, DATASET and VARIABLE for our graph. Click on the Library drop down arrow,
and select “MYLIB”. Click on the Data Set drop down arrow, and select ADSL. Click on the Category drop down
arrow and select “SEX”. (Figure 2C).
At this stage we have a graph with a bar chart showing the frequency of the gender for all the subjects in the study.
We have a place holder title at the top, a place holder footnote at the bottom, and a bar chart of gender frequency.
(Figure 2).
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Figure 2A Selecting Vertical Bar Chart from Graph Gallery

Figure 2B

Figure 2C
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Figure 2 Vertical Bar Chart of Gender Frequency

EXAMPLE 3: CREATE A BAR CHART OF GENDER FREQUENCY BY TREATMENT ARM
Right click on the plot; you will see the standard graph pop-up menu as shown in Figure 3A. Select “Assign Data”, a
pop-up window (Figure 3B) will allow you reassign the variable or do other settings for this plot. Click on the Group
drop down arrow and select “ARM”, and then click OK.
A stacked bar chart of gender frequency is shown in Figure 3. If you move the mouse over on the bar, there is a popup tooltip window showing the statistics of the bar (Figure 3C).

Figure 3A

Figure 3B
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Figure 3 Vertical Bar Chart of Gender Frequency by Treatment Arm

Figure 3C

EXAMPLE 4: SIDE BY SIDE BAR CHART
If you like to have a side-by-side bar chart instead of a stacked bar chart, you can go to the “Assign Data” window,
select “Panel Variables” tab, click on the Column drop down arrow and select “ARM”. (Figure 4A) Then click OK.
Figure 4 is shown the plots that you like.
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Figure 4A

Figure 4 Side by Side Vertical Bar Chart of Gender Frequency by Treatment Arm

EXAMPLE 5: TITLES AND FOOTNOTES
At this point, double click on the title and enter the title you want, like “Gender Frequency by Treatment Arm”. You
could do the same thing with footnote; enter the footnote “Example for PharaSUG 2012”. If you just want to remove
the title or the footnote, right click and select “Remove Title” or “Remove Footnote”. Figure 5 shows the graph with a
title and a footnote.
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Figure 5 Titles and Footnotes

EXAMPLE 6: VIEW GTL CODE
The Designer is not only an interactive process to create statistical graphs, its GTL template is built for us step by
step during the whole process. So the Designer is a very good learning tool for GTL. You can view the GTL template
by selecting View->Code, as shown in Figure 6.

Figure 6 GTL Template in the Code Window
The GTL template and PROC SGRENDER code are displayed for the active graph as shown below. You can leave
the code view open as you build the graph step by step.
proc template;
define statgraph sgdesign;
dynamic _SEX _ARM _ARM2;
dynamic _panelnumber_;
begingraph;
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entrytitle _id='title' halign=center 'Gender Frequency by Treatment Arm' /;
entryfootnote _id='footnote' halign=left 'Example for PharmaSUG 2012' /;
layout datalattice _id='datalattice2' columnvar=_ARM2 / panelnumber=_panelnumber_
cellheightmin=1 cellwidthmin=1 column2datarange=unionall
columnaxisopts=(label='Gender') columndatarange=unionall columngutter=3
headerlabeldisplay=value row2datarange=unionall rowdatarange=unionall rowgutter=3;
layout prototype _id='prototype2' / ;
barchart _id='bar' x=_SEX / group=_ARM name='bar' stat=freq;
endlayout;
endlayout;
endgraph;
end;
run;
proc sgrender data=MYLIB.ADSL template=sgdesign;
dynamic _SEX="SEX" _ARM="ARM" _ARM2="ARM";
run;

EXAMPLE 7: CHANGE PLOT PROPERTIES
Right click on the plots and select “Plot Properties”. The Plot Properties dialog is shown in Figure 7A. This dialog can
be used to set or modify visual properties for the plot. Select the Bar tab, and we can adjust the width of the bar.
Figure 7 shows the bar chart with smaller width after the adjustment.
To save the graph, select File->Save As and then specify the filename and type. You can save a graph as an ODS
Graphics Designer (SGD) file, an image file, an HTML file, or a PostScript file. The SGD file can later be opened,
edited, or continually developed in the Designer.

Figure 7A

Figure 7B
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Figure 7 Change Plot Properties

EXAMPLE 8: CHANGE AXIS PROPERTIES
Right click on the plots and select “Axis Properties”. The Axis Properties dialog is shown in Figure 8A. This dialog can
be used to customize the axis. Select the Advanced tab, and we can adjust the axis range as in Figure 8B. Figure 8
shows the bar chart with a different axis range.

Figure 8A

Figure 8B
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Figure 8 Change Axis Properties

EXAMPLE 9: CHANGE TO A DIFFERENT VARIABLE
As the GTL template been built by the Designer, you can easily apply the template to a different data set or variable.
Right click the bar chart (Figure 9A), and select “Assign Data”. You can change the variable to RACEALL from SEX
as in Figure 9B. Figure 9 shows the vertical bar chart of race frequency by treatment arm.

Figure 9A

Figure 9B
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Figure 9 Vertical Bar Chart of Race Frequency

EXAMPLE 10: HISTOGRAM OF AGE DISTRIBUTION BY TREATMENT ARM
In previous exercises, we’re looking at categorical variables, let’s check the distribution of continuous variables using
histograms.
Select the Basic tab from the Graph Gallery. Click the Histogram. Click OK.
The Assign Data dialog is displayed with the data settings for the histogram (Figure 10A).
Click on the drop down arrow of the X role, and select the variable AGE.
Click Panel Variables tab, select ARM for Column variable (Figure 10B).
We have a graph with histograms showing the distribution of age by treatment group in Figure 10. You can modify the
titles and footnotes accordingly.

Figure 10A

Figure 10B
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Figure 10 Histogram of Age Distribution by Treatment Group

EXAMPLE 11: ADD A NORMAL DENSITY CURVE.
Once a graph is open in the workspace, the “Plot Layers” and “Insets” panels on the left side of Elements pane are
active.
To add a Normal Curve, click and hold the mouse button on the icon for “Normal”, and drag and drop it on top of the
histogram. The “Assign Data” dialog for the Normal Curve will be displayed as shown in Figure 11A.
Notice in Figure 11A, the settings for Library and Data Set are grayed out, and cannot be changed. This is because
all plots in one cell of a graph must come from the same data set.
Notice the “Fit to existing plot” check box in Figure 11A. We’ll accept this setting since we want to use the same X
variable as the histogram.
A Normal Density Curve is added to the graph for the same AGE variable as shown in Figure 11.

Figure 11A
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Figure 11 Histogram of Age Distribution by Treatment Group with Normal Curves

EXAMPLE 12: CHANGE PLOT PROPERTIES
Right click on the normal density curve. The curve will be selected, and the Graph pop-up menu is shown. Select the
“Plot Properties” menu item. The Cell Properties dialog is displayed as shown in Figure 12A. Notice the assigned
style element is GraphFit. Change the Pattern to dotted line. The resulting graph is shown in Figure 12.

Figure 12A
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Figure 12 Normal Curves Changed to Dotted Line

EXAMPLE 13: MEAN MEASUREMENTS OVER TIME
A graph of mean measurement over time is one of the most commonly used statistical graphs for data exploration
and presentation in clinical research. We’ll show you how to create the graph step by step using the Designer.
Select the Analytical tab from the Graph Gallery (Figure 13A).
Click the Means. Click OK. A graph will appear showing mean values with horizontal error bars and the Assign Data
dialog (Figure 13B).
Notice this graph is merely a place holder to indicate the type of plot being customized. It uses the CARMEAN data
set from WORK library (Figure 13C).
For our graph, we need to provide the LIBRARY, DATASET and VARIABLES (X, Y, and GROUP) according to
Figure 13D.
Click on “More Variables…” to assign variables for the error bars (Figure 13E).

Figure 13A
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Figure 13B

Figure 13C

Figure 13D

Figure 13E

15

After we assigned variables following the steps above (Figure 13F), a graph of mean values with error bars over time
is showing in Figure 13.

Figure 13F

Figure 13 Mean Values with Error Bars over Time

EXAMPLE 14: ADD SERIES LINES
To link the mean values with connected lines, click and hold the mouse button on the icon for “Series” from Plot
Layers, drag and drop it on top of the plots in exercise 13 (Figure 14A). A “Assign Data” dialog for the series plot will
be displayed as shown in Figure 14B. Assign the proper variables as shown in Figure 14C. Click OK, a graph of
mean measurements over time with error bars by treatment arm is shown in Figure 14.
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Figure 14A

Figure 14B

Figure 14C

Figure 14 Mean Measurements with Error Bars over Time
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EXAMPLE 15: ADD A CELL LEGEND
To add a discrete legend to the graph, click and drag the Discrete Legend icon from the Insets panel to the graph
cell. You can also right-click inside the graph and choose “Add an Element”. Then click the legend icon from the
Elements pop-up window. The legend is placed near the location where the icon is dropped.
Right click the legend, and then select Legend Properties (Figure 15A).
The Legend Properties dialog opens. Select “Bottom Right” for the Position (Figure 15B). Click OK.
A legend with 4 rows (two for scatter plot and two for series plot) has been added to the graph as shown in Figure
15C.

Figure 15A

Figure 15B
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Figure 15C
If you feel the legend for series is good enough, you can right click the legend, and then select Legend Contents. The
Legend Contents dialog opens, you can de-select scatter. (Figure 15D)
The final graph with legend been added to the data area is shown in Figure 15.

Figure 15D

Figure 15 Legend been Added Inside the Data Area
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EXAMPLE 16: HIGHLIGHT THE TREATMENT PERIOD
We can add a block plot to the graph to highlight the treatment period. Click and drag the Block icon from the Plot
Layers panel to the graph. Set the variable BLOCKV as the Block variable and AVISTN as the X variable (Figure
16A).
In the Cell Properties window, you can check Value to show the variable value on the graph (Figure 16B). You can
specify the location of the value too; in this case, we want the value “Treatment Period” to show at center of the
bottom (Figure 16C).
The graph shows treatment period in different colors as in Figure 16.

Figure 16A

Figure 16B

Figure 16 Treatment Period is Shown in Different Colors
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Figure 16C

EXAMPLE 17: MULTI-CELL GRAPH
So far, we have been working with a single cell graph, which has one graph area but may have multiple plots overlaid
in the common data area. The data area, along with the axes is called a “Cell”. A graph can contain multiple cells,
and each cell can have one or more plots. The cells are in a regular grid of rows and columns. We’ll add a stacked
vertical bar chart below the plots in exercise 16 to add the information of number of subjects at each visit to the
graph.
Right click the plots, and select “Add a Row” from the graph pop-up menu as shown in Figure 17A.
The graph region is split horizontally with a new row been added to the graph. Now the graph has two rows of cells,
and only one column as shown in Figure 17B. The previous graph is reformatted to fit the upper cell, and the new
empty cell has a hint “drop a plot here”.
Click on the Bar icon in the Plot Layers panel, drag and drop it in the empty cell area. The familiar Assign Data
dialog is displayed as shown in Figure 17C.

Figure 17A

Figure 17B
Set AVISITN as Category variable, AVAL_N as Response variable, and ARM as Group variable. Click OK.
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The vertical bar chart is added to the lower cell, alone with its own axis as shown in Figure 17. You can adjust the
heights of the graph cells to make them looks better.

Figure 17C

Figure 17 Multi-Cell Graph with Numbers of Subject Shown In the Bottom

CONCLUSION
ODS Graphics Designer is a very useful tool to assist statisticians and clinicians to explore the clinical data and
interpret the results of the clinical studies easily and quickly. It can also help programmers to learn the GTL. There
are other nice features of the Designer which are not covered in this paper due to the limit of length, such as manage
and create your own Graph Gallery, shared variable graphs, Style Editor, run graphs in batch mode. Please refer to
the Designer User’s Guide for how to use them.
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