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ABSTRACT 
Hastily using confidential or draft listings and tables produced in SAS® for business needs increases the risk 
associated with misusing or misinterpreting the results.  A viable solution to reduce that risk is to use a visible 
watermark embedded in the SAS outputs such as a pale image or text displayed and/or printed behind the text.  This 
paper will introduce a method of watermarking the output directly from SAS through an interface with Microsoft® 
Office Word (Word) without using Proc Template and ODS. 

INTRODUCTION 
Customers regularly use the reports produced in SAS for business needs; if they are in draft or confidential, this can 
run the risk of misusing or misinterpreting the results.  To prevent this, the word “Draft” or “Confidential” is placed on 
or close to the margin area of the paper to emphasize that the report is neither final nor unrestricted.  However, it can 
be easily overlooked due to the margin position and/or small font size used.  Incorporating a visible watermark into 
the report provided a better solution that increased awareness and reminded our reviewers or users of the report’s 
status. 

The visible watermark is a pale image or text displayed and/or printed “behind” text in the document and a valuable 
unobtrusive way to display important information that cannot be missed by the reader such as the fact that the 
document is a draft version or confidential. 

Starting with SAS 9.1, using ODS with a template predefined by Proc Template, an image can be placed behind a 
table or listing.  However, in many companies tables or listings are directly generated in .rtf or .doc format using 
home-grown macros (systems) and not ODS (Zhou, 2001; Zhou, 2002; Qi and Zhang, 2003).  This paper introduces 
an alternative to using SAS to place a watermark in a report. 

TECHNIQUE AND MECHANISM 
There are four steps required to create a SAS report with a watermark: 

1. Create a Watermark Template in Word 

2. Open the Watermark Template in Word with SAS 

3. Insert the SAS Output into Word with SAS 

4. Use SAS to Save the Document with Desired Page Attributes 

CREATE A WATERMARK TEMPLATE IN WORD 
The first step in the process is to create a watermark template using Word.  (Note: This paper discusses how to add a 
watermark using Word 2003.  The steps to get to the Printed Watermark dialog box are different in other Word 
versions e.g., in Word 2007 use Page Layout>Watermark>Custom Watermark.) 

To insert a watermark: 

1. Select Format from the standard toolbar. 

2. On the Format menu, point to Background, and then click Printed Watermark. 

3. In the Printed Watermark dialog box, select one of the two options: Picture watermark or Text watermark. 

The Text watermark option is effortless and appropriate to use for most reports.  To use the Text watermark 
feature: 

1. In the Printed Watermark dialog box, click the radio button next to Text watermark. 

2. In the Text field you can either select from the list in the drop-down menu or you can type directly in the Text 
field. 

3. The default Font is Times New Roman, but any font on the system can be chosen and will appear in the drop-
down menu. 
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4. It is recommended that the default values for Size, Color, Semitransparent, and Layout fields are used so that 
the watermark does not distract from the document text and is just dark enough to print and be readable behind 
the text. 

For a more sophisticated or deluxe custom watermark, select the Picture watermark option; this permits the use of a 
picture file such as the company’s logo.  If this option is used, when you click the Select Picture button, a dialog box 
will open that allows browsing the hard drive for the picture to use.  It is best apply the defaults for Scale and leave 
the box next to Washout checked so that the watermark does not interfere with the readability of the document.  Use 
a program such as Photoshop or Paint to create a custom picture file to change the rotation, transparency, and color 
of the picture. 

Once the watermark is created save it as either a .dot or .doc file with the standard margins and desired page 
orientation and store it in a shared network server with read-only access permissions.  Note: a separate file will be 
needed for each watermark type such as draft, confidential, or image. 

OPEN THE WATERMARK TEMPLATE IN WORD 
Once the watermark template is designed and stored, the next step is to use SAS to automate the process. 

In order for a client/server communication link to be established, both SAS and Word must be running.  Therefore, for 
the first iteration, it is necessary to programmatically launch Word from a SAS session. 

1. Establish the linkage between SAS and Word via the DDE triplet using the following filename statement: 

filename word DDE 'Winword|System' lrecl=1000; 

2. Verify that the two system options NOXWAIT and NOXSYNC are enabled prior to executing the statement in 
step 3. 

The NOXWAIT option specifies that the DOS Command Prompt window disappears without having to type 
EXIT when the process is finished, and the NOXSYNC specifies that the process should execute asynchronously 
(i.e., control is returned immediately to the SAS System and the command continues executing without 
interfering with your SAS session). 

3. Launch Word from a SAS session using the following statement: 

%let rc=%sysfunc(system(start winword)); 

There are several techniques available to launch Word from SAS, and this is the simplest one. 

If the watermark template file will be shared by more than one user, it will be necessary to programmatically copy 
the file to a temporary folder, e.g., C:\temp, to avoid the Read-only pop-up window in Word. 

1. Use the following X statement with the DOS copy command to copy the file: 

   x "%str(copy %"J:\WM\&watermark..doc%" %"C:\temp\&watermark..doc%")"; 

The &watermark is a macro variable for the name of a watermark template file defined by a %let statement 
or a macro parameter.  The double quotation marks are used rather than the single quotation marks due to the 
embedded macro variable.  

2. Open the template file by sending the FileOpen WordBasic command to Word with a data _null_ step: 

   data _null_; 
      file word; 
      put '[FileOpen .Name = "' "C:\temp\&watermark..doc" '"]'; 
   run; 

INSERT THE SAS OUTPUT INTO WORD 
After the watermark template is open in Word, the next step is to insert your SAS output into the template.  The 
FileOpen WordBasic command for the SAS output cannot be used because it will open the file with a new 
document in Word. 

Execute the following InsertFile WordBasic command to insert the SAS report into Word:  

    
  data _null_; 
     file word; 
     put '[InsertFile .Name ="' "J:\project\study\output\demog.doc" '" ]'; 
  run; 
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SAVE THE DOCUMENT WITH THE DESIRED MARGINS AND PAGE ORIENTATION 
When the SAS output is inserted into the Word template, the page attributes of the SAS output will be lost.  If the 
margins and page orientation of the SAS output differs from the watermark template, these attributes will need to be 
recreated in the Word document. 

1. Execute the FilePageSetup WordBasic command. 

The arguments for the FilePageSetup statement correspond to the options in the File>Page Setup dialog box 
in Word. 

2. Use the following syntax for FilePageSetup: 

FilePageSetup [.Tab = number] [, .TopMargin = number or text] [, .BottomMargin = number or text] [, 
.LeftMargin = number or text] [, .RightMargin = number or text] [, .Gutter = number or text] [, .PageWidth 
= number or text] [, .PageHeight = number or text] [, .Orientation = number] [, .FirstPage = number] [, 
.OtherPages = number] [, .VertAlign = number] [, .ApplyPropsTo = number] [, .Default] [, .FacingPages 
= number] [, .HeaderDistance = number or text] [, .FooterDistance = number or text] [, .SectionStart = 
number] [, .OddAndEvenPages = number] [, .DifferentFirstPage = number] [, .Endnotes = number] [, 
.LineNum = number] [, .StartingNum = number] [, .FromText = number or text] [, .CountBy = number] [, 
.NumMode = number] 

The arguments and their explanations can be found in Word 95 WordBasic Reference (Microsoft Press, 1995).  
For convenience, the key arguments are listed in the following table. 

Argument Explanation 

.TopMargin The distance between the top edge of the page and the top boundary of the body text 
in points or a text measurement. 

.BottomMargin The distance between the bottom edge of the page and the bottom boundary of the 
body text in points or a text measurement. 

.LeftMargin The distance between the left edge of the page and the left boundary of the body text 
in points or a text measurement. 

.RightMargin The distance between the right edge of the page and the right boundary of the body 
text in points or a text measurement. 

.PageWidth The width of the page in points or a text measurement. 

.PageHeight The height of the page in points or a text measurement. 

.Orientation The orientation of the page:  

     0 (zero) – Portrait; 1 – Landscape 

.HeaderDistance Distance of header from the top of the page. 

.FooterDistance Distance of footer from the bottom of the page. 

3. Set up the page attributes.  Following  is sample code to set up the page attributes with landscape orientation 
and one-inch for each margin: 

   data _null_; 
      file word; 
      put '[FilePageSetup ' 
          '.Orientation =1,' 
          '.PageWidth ="11.5 in ",'  
          '.PageHeight ="8.5 in ",'  
          '.TopMargin ="1 in ",' 
          '.BottomMargin ="1 in ",' 
          '.LeftMargin ="1 in ",' 
          '.RightMargin ="1 in "]'; 
   run; 
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4. Save the document and close the file with the following code: 

   data _null_; 
      file word; 
      put "[FileSaveAs" 
          ".Name="J:\project\study\output\demog.doc "," 
          ".Format=0," 
          ".AddToMru=1]"; 
       put "[FileClose]"; 
    run; 

The detailed arguments and their explanations of the FileSaveAs command can be found in Xu and Zhou 
(2007). 

MACRO %WATERMARK 
By following the steps in the previous sections, a watermarked Word document was programmatically created using 
SAS.  To facilitate the steps, a SAS macro entitled %watermark was developed (see Appendix for details) that 
automates the process of generating the visible watermark from creating and opening the watermark template to 
saving and closing the Word document.  The following table lists the five keyword parameters. 

Parameter Definition 

Watermark: Define the name of watermark template. 

In: Define the path and name of the input SAS output, e.g., C:\temp\demog.doc. 

Out: Define the path and name of the final document to be saved.  By default, the path and name 
defined by the In parameter are used. 

Margin: Define the page margins in inches with four variants, separated from each other by a space, and 
representing top, bottom, left, and right margins, respectively.  The default is 1.25 inches for the 
top margin and one inch for the rest, which meets the FDA requirements.  Any number, including 
decimals, can be used to define the parameter. 

O: Define the page orientation, with L for landscape (default) or P for portrait. 

Following is a simple macro call to %watermark: 

%watermark(watermark=draft, in=c:\temp\demog.doc); 

CONCLUSION 
When sharing Microsoft Office Word documents, watermarks can be the most effective way to designate their life 
cycle status or the importance of the data.  For example, using "Draft" to convey the content is not final when the data 
is not to be released as official communication.  With just a little tweaking using the techniques described in this 
paper to add a visible text or image watermark, the comprehension of the SAS output status can be significantly 
increased. 
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APPENDIX 
%macro watermark(watermark=, in=, out=, margin=1.25 1 1 1, o=L); 
   %if %length(&orientation)>0 %then  
      %let o=%upcase(%substr(&orientation,1,1)); 
   %else %let o=P; 
   %if %length(&out)=0 %then %let out=&in; 
   %if &o=L %then %do; 
      %do i = 1 %to 4; 
         %let m&i=%scan(&margin, &i, ' ') in; 
      %end; 
      %let o=1; 
      %let pagewd=11.5 in; 
      %let pageht=8.5 in; 
   %end; 
   %else %do; 
      %do i = 1 %to 4; 
         %let m&i=%scan(&margin, &i, ' ') in; 
      %end; 
      %let o=0; 
      %let pagewd=8.5 in; 
      %let pageht=11.5 in; 
   %end; 
 
   filename word DDE 'Winword|system' lrecl=1000; 
 
   options noxwait noxsync; 
   x "%str(copy %"J:\WM\&watermark..doc%" %"C:\temp\&watermark..doc%") "; 
    
   filename watermrk "C:\temp\&watermark..doc"; 
 
     %let rc=%sysfunc(system(start winword)); 
 
   data _null_; 
      file word; 
      put '[FileOpen.Name = "' "C:\temp\&watermark..doc" '"]'; 
      put '[Insertfile .Name ="' "&in" '" ]'; 
      put '[FilePageSetup ' 
          '.Orientation =' "&o" ',' 
          '.PageWidth ="' "&pagewd" '",'  
          '.PageHeight ="' "pageht" '",'  
          '.TopMargin ="' "&m1" '",' 
          '.BottomMargin ="' "&m2" '",' 
          '.LeftMargin ="' "&m3" '",' 
          '.RightMargin ="' "&m4" '"]'; 
      put "[FileSaveAs" 
          ".Name=""&out""," 
          ".Format=0," 
          ".AddToMru=1"; 
      put "[FileClose]"; 
   run; 
%mend watermark; 


